Commit 4f68315b authored by Daniela Felix's avatar Daniela Felix
Browse files

update

parent 15fd5cdb
Pipeline #222656 passed with stage
in 13 seconds
......@@ -302,11 +302,11 @@
</div>
</p>
<hr>
<!-- ROBERT -->
<!-- ROBERT MOYA-->
<h4> DESIGN AND PRINT @Roberto</h4>
<hr>
<!-- PHASE III -->
<!-- PHASE III JEFFERY Y CAMILO-->
<h3>PHASE III - SOFTWARE</h3>
<p>In order to control the machine we decided to use bCNC, this is the process we followed to get the machine going:<br>
<h4>Using Raspberry Pi @Jeffery</h4>
......@@ -316,7 +316,7 @@
</p>
<span class="image"><img src="img/w9/Raspberry-Pi.jpg" alt="" height="500"/></span>
<h4>Installing operating system</h4></p>
<h4>Installing operating system @Jeffery </h4></p>
<p style=text-align:justify;>To install the operating system on our Raspberry we will use Raspberry Pi Imager that we can download from the following link
<a href="https://www.raspberrypi.org/software/" target="_Blank"> Raspberry Pi Imager</a> Once we download and install it, we can choose the operating
system that we want to install. this will be installed in a micro usb memory
......@@ -349,10 +349,7 @@
<img src="img/w9/inst3.jpg" alt="print" class="img-responsive col-4 col-xs-6"/>
<img src="img/w9/1.jpg" alt="print" class="img-responsive col-4 col-xs-6"/>
</div>
</p>
<section id="programming">
<h4>Programming</h4>
<p>The ATtiny44 used on the board need to be programmed to achieve the laser and end switch sensing and react accordantly. I first start using Platformio to write the program as is easier for me use VS code that writhing inn the ArduinoIDE, but some how the SoftwareSerial.h wasn't working on the ATtiny44 when programing with Platformio. And that force me to move to the ArduinoIDE.</p>
......@@ -363,9 +360,13 @@
<p>After some test it was working as intended but the program wasn't turning the signal off once it was sended, this bug take me a while to solve. I initially think that the state machine of the code was some how on and infinite loop. But after a lunch brake I finally catch my mistake it was a <samp>digitalWrite(ENDSTOP_PIN_X, INPUT)</samp> where it should be <samp>pinMode(ENDSTOP_PIN_X,INPUT)</samp></p>
<a href="./img/machine/laser-zeroing.ino" target="_blank" rel="noopener noreferrer" class="btn btn-default" download>Get the .ino file</a>
</section>
<h4>bCNC @Camilo</h4>
<hr>
<!-- PHASE IV -->
<!-- PHASE IV - CAMILO -->
<h3>PHASE IV - TESTING</h3>
<p>You can find the result of our group <a href="machine.html"> <b>here</b></a>.</p>
<div class="row">
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment